Linux Mint Romania
Dorim să va anunțăm că acum ne găsiți la noua adresă: www.linuxmint.ro
Acolo puteți cere ajutor.

Probleme driver video Intel

Vezi subiectul anterior Vezi subiectul urmator In jos

Probleme driver video Intel

Mesaj Scris de Nicu la data de Mier 13 Apr 2011, 13:16

Pentru că folosesc Linux Mint Debian Edition şi am vrut să testez noul driver Intel despre care se tot discuta cât e de performant după noile actualizări, la un moment dat (acum o lună şi ceva) m-a apucat curajul să folosesc depozitul de software instabil, am făcut o grămadă de actualizări şi mi-am repornit agregatul.

Surpriza neplăcută a fost că am rămas fără mediul grafic, iar în jurnalul Xorg am găsit asta:
(EE) intel(0): Detected a hung GPU, disabling acceleration.

Pentru că am ştiut de unde mi s-a tras problema am comentat depozitul de pachete instabile, am executat:
apt-get remove xserver-xorg xserver-xorg-video-intel
apt-get update
apt-get remove xserver-xorg xserver-xorg-video-intel
Adică am dezinstalat serverul grafic şi driverul Intel, apoi am preluat lista celor mai noi pachete din depozitul normal LMDE (Debian Testing) şi am reinstalat pachetele respective (cu dependinţe, desigur). Dar asta abia după ce am intrat în Recovery Mode, pentru că modul grafic nu mai pornea şi eram complet blocat dacă încercam să-l pornesc.

Povestea s-a încheiat cu succes. Am revenit la vechiul driver Intel şi totul a fost în regulă. În seara asta, însă, pachetele respective au ajuns în depozitul de teste, cel normal pentru LMDE. Speram că le repară cineva, dar se pare că nu s-a întâmplat. Ca atare, după ce am repornit calculatorul am întâmpinat aceeaşi problemă. De data asta a devenit mai complicată situaţia, pentru că singura modalitate să revin la driverul vechi ar fi fost să dezinstalez din nou serverul grafic (Xorg) şi să instalez printr-o cerere manuală pachetele mai vechi. N-am vrut să fac asta pentru că pot trăi fără acceleraţie video pe Intel GMA 3100, aşa că am intrat din nou în Recovery Mode, după care am executat comanda:
Xorg -configure
Asta a generat fișierul /root/xorg.conf.new - în care am intrat cu editorul nano şi am editat linia cu driverul video din secţiunea Device. Am făcut-o aşa:
Driver "fbdev"
După asta am repornit calculatorul şi mi-am putut vedea de treabă în continuare. Problema driverului nu se întâmplă doar pe distribuţiile bazate pe Ubuntu şi Debian, ci şi pe Arch, Fedora şi altele, deci pentru distribuţiile care nu se bazează pe APT folosiţi doar metodele, nu şi comenzile apt-get pe care le-am indicat, ci echivalentele lor (de exemplu Fedora/CentOS: yum install, yum remove).

P.S. Nu vă doresc să vă bateţi de problema asta, dar sper să vă fie de folos informaţiile astea în cazul în care o păţiţi.
avatar
Nicu

Mesaje : 170
Data de inscriere : 10/05/2010
Varsta : 38
Localizare : Bucureşti

http://www.phpfusion.ro/

Sus In jos

Vezi subiectul anterior Vezi subiectul urmator Sus

- Subiecte similare

 
Permisiunile acestui forum:
Nu puteti raspunde la subiectele acestui forum